1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA "Close all positions at profit target" closed all positions at loss ???

Discussion in 'Forex Trading Systems and Strategies' started by Johncobb50, Aug 4, 2012.

  1. Johncobb50

    Johncobb50 Recruit

    Joined:
    Jul 5, 2012
    Messages:
    2
    Likes Received:
    0
    Hello,
    I use Expet Advisor - "Close all positions at profit target".
    Last Friday this EA has closed my open positions when the total was in negative (with a loss). Why???
    Did this happend to anyone?
    I have noticed that just before the EA closed my positions there was a gap in trading, would this be a reason? Is there an error in this EA?
    Anyone that has had any experence similar to mine please comment.
    Can anybody tell me who else can I ask about this EA and if that could have happend because the gap in trading.
    Waiting for comments.
    John
     
  2. Pharaoh

    Pharaoh Colonel

    Joined:
    Oct 3, 2007
    Messages:
    19,678
    Likes Received:
    2,225
    I'd need to know more about the logic of the Close All Positions EA. It's possible that the gap may have confused it.

    Then again, if you are trying to close positions at a profit target, why not just set TP on each position?
     
  3. ilearn2t

    ilearn2t Sergeant Major

    Joined:
    Jul 19, 2012
    Messages:
    711
    Likes Received:
    69
    Hello Johncobb50

    During volatile trading the StopLoss level for closing your script (Slippage) is broken and your orders will close below the target range.

    To confirm/check this; go to your Terminals "Account History" window, right click on any closed order, stroll down to "Comments" and click on it, you should now have a new comments window in your terminal, look at your problem orders and if you see "sl/gap" then your script file is ok. If still in doubt simply bin it and program a new file or download another free copy.

    Good luck
    ilearn2t
     
  4. FringFX

    FringFX Sergeant

    Joined:
    Jul 18, 2012
    Messages:
    391
    Likes Received:
    1
    There is probably an error on the coding part of that EA. The gap could definitely be a culprit in this situation but you really need to scrutinize everything.
    You should always test your EA extensively on demo or a small live account before going live fully.
     

Share This Page